Sprite Deleted Itself



  • I was editing a fairly detailed sprite with many frames etc. I had a random error message that would normally appear when coding but appeared in the image editor. It seems to have deleted the whole sprite which was the main avatar for my almost finished game 128x128. Stupidly high resolution I know... The file has now reset as a normal image 100x100 instead of a tiled image. Anyone else encountered this issue?


  • F

    @nintisonfire iv had image editor crashes but very very rare always best to save periodically especially with detailed stuff as a fail safe.



  • Thanks for the response. This was different. I also get crashes that take me back to the switch home menu and save periodically. This bug literally took my image file and reset it to a 100x100 normal with all the pixel art deleted. The keyboard also opened in the image editor and it then took me to the fuze menu.


  • Fuze Team

    That is very strange. Have you downloaded the latest patch?



  • @pianofire Yes I have downloadedthe new patch. I managed to re-create the error with that file (which is now blank of course).I think by trying to cut and paste repeatedly as that is when this bug happened. I get an error message LINE 1135 FUNCTION update() "can't create an image this size, -(very large number for x and y) width and height must be positive."
    This does not delete the random scribbles but does open the keyboard in image editor and the menu. I will try upload images after work.


  • Fuze Team

    Thanks if you can detail the steps to reproduce that would be very useful



  • I have attached the images that show what appeared on my screen when the error happened a second time but like I said the damage had already been done where it had deleted the pixel art. Unfortunately I am struggling to re-enact it a third time. I can crash FUZE traditionally where it closes the software by spamming copy and pasting. I can't seem to get this error message again. Sorry I could not provide you with clear and effective guidance on how to reproduce the bug.

    4f9a30b4-fe23-41e0-beb0-23853a7ebe3e-image.png

    23913df4-cbcc-45f4-9932-93e79efc7c58-image.png

    853eeb73-d661-49e9-9c9d-787e50a59311-image.png


  • Fuze Team

    OK I will see if I can reproduce it



  • I'm able to reproduce it successfully, and that means a fix will be on the way. Thank you for the report!


Log in to reply